Zowe or rocket error?

Hi All, Is there a character limit for the zowe zos-ssh issue command? I am trying to run a script that takes few arguments one of which is a token that has a lot of characters. When I run this on a ci pipeline, it errors out without any message. Example: zowe zos-ssh issue command “/path/Rocket/bin/python script.py -x $var -y $var2……-k $token” —host http://xyz.com —port 1234

When I run the same with a different auth mechanism i.e an api key -k $key the command works perfectly fine. Could this be zowe or rocket error ? Can someone please advise how to overcome this issue.


It seems like you’re encountering an issue with a command that includes a long token as an argument. While the Zowe documentation does not explicitly mention a character limit for the zos-ssh issue command, it’s possible that you’re hitting a limit imposed by the underlying SSH server or the environment where the CI pipeline is running.

Here are a few steps you can take to troubleshoot and potentially resolve the issue:

Check for Argument Length Limitations: Some systems have a maximum length for the command line, which can cause issues if your token is very long. You can check the system’s limits and see if the token exceeds this length.

Inspect the CI Pipeline Configuration: Ensure that there are no restrictions or limitations in the CI pipeline configuration that might be causing the command to fail when a long token is used.

Use a File for the Token: Instead of passing the token directly as an argument, you could try writing the token to a file and then passing the file path to the script. This can help if the issue is related to the length of the command.

Debugging the CI Pipeline: If the pipeline fails without any message, you might want to add some debugging steps to your CI pipeline to capture more information about the failure. This could include redirecting error outputs to a file or setting verbose flags for the commands being run.

I hope the information may helps you.

Best regards,
Yvonne Rhodes